GP Connect Issues

Incident Report for Graphnet Health Ltd

Update

We continue to investigate the issues with GP Connect as a high priority and are working with NHSE Digital to find a resolution.
Posted Aug 18, 2026 - 14:11 BST

Update

We are continuing to investigate the issues with the GP Connect service and are in communication with NHSE Digital to find the cause of the errors.
Posted Aug 18, 2026 - 11:31 BST

Investigating

We are currently experiencing issues with GP Connect calls. We have raised this with NHSE Digital. We are investigating it as a priority.
Posted Aug 18, 2026 - 09:20 BST
This incident affects: CareCentric - Live - User Interface (GP Connect).